• Welcome to the WDWMAGIC.COM Forums!
    Please take a look around, and feel free to sign up and join the community.You can use your Twitter or Facebook account to sign up, or register directly.

MagicBand+ announced

DisneyfanMA

Well-Known Member
For those who haven't ordered yet or on the fence about what to get. I ordered MB2 for 20 bucks ea on 8/17. I got them today. Main use case for us is park entry and boarding rides. We are off property so not sure they can do anything else for us. Costs being equal MB+ fun, but looking to shave a tiny bit savings and time these will work good enough.
 

Attachments

  • 20220825_133237.jpg
    20220825_133237.jpg
    164.8 KB · Views: 22

Chip Chipperson

Well-Known Member
I ordered my MB+'s on July 27th for an October 1st arrival and just got my shipping confirmation e-mail this morning so it looks like they're starting to catch up, hopefully.

Still no shipping notification for me, but I do see that the order status online has changed to "Shipped" with a USPS tracking number. The USPS tracking status just says "USPS Awaiting Package," but at least I know a label has been created and can track the progress - although it would be nice to get an actual shipping email so I don't have to log into Disney's molasses-slow website to find the tracking number. I never received an order confirmation email, either, so they're 0-for-2 on communications with this order.
 

Chip Chipperson

Well-Known Member
I think Apple has been purposely careful to not get into the game of creating function specific watch faces for outside companies that Apple cannot fully control.

Given Disney IT's less-than-stellar track record, that's a smart move on Apple's part. I'm sure they'd rather not have to deal with customer complaints when Disney's tech fails (or any other company, for that matter).
 

pdude81

Well-Known Member
Disney makes zero money on you using your apple watch as a device to play games. Plus they'd have to develop and maintain that software in addition to what they're aleady doing. And if they even charged for that watch face app, they'd lose 30% of the cash to Apple each time. They probably make 15 bucks off each MB+ they sell instead of 70% of a 3 dollar app.
 

MickeyLuv'r

Well-Known Member
Wanted to share in this thread we are just back, and we were never able to get all our bands working properly at the same time. They arrived before our visit, and we charged them, and tried to pair them before the trip. We were not able to play the games.

During the trip though, we'd get one or two to work for a few hours, but not all at once. Then a few hours later or the next day, that band would stop working. I think one of them never fully worked.

We spent more than 2 hours in GS trying to get them to fully pair properly, but even the CM could not get them to fully pair. We got one of them to work for few hours. She said it was a known issue with Android devices. CM said w/Android it helps if everything is fully charged, but that didn't seem to do anything. She filled out an incident report.

We tried everything, and it was frustrating. She even had us delete and replace MDE. Nothing. We all have Android devices, but all different ones. Maybe they pair better with Apple?

If even the GS CM can't get the stupid things to work...


The bands did work like regular M-bands, and sometimes they would randomly light up. Sometimes we could get one or two to scan at the statues, but then the next day or so, the ones we had collected would disappear, like we had not collected any. We could not collect Pinocchio at all. (Though the audio would play.)

They also kept popping off our wrists like no Magicbands before. Right form the first day, but the problem got worse the more we took them off.

Also, we knew we'd have to charge them, but it was decidedly a hassle. We now have our phone, our band, and a portable powerbank to charge each night. So the whole night stand was covered in two people's cables/devices. Luckily our hotel room had enough outlets. In the past, I generally did not need a powerbank at WDW, but this trip we did.

Also, in the morning, in the heat of trying to eat, get ready, get G+, get to the parks, remembering the band was one more thing to have to keep track of. By itself, no big deal, but with everything else it was just one more thing to have to remember.

They were a complete waste of money, IMO. Despite the fact they did not work, and did not stay on our wrists, we were not offered a refund, which was also disappointing. CM gave us ONE round of G+passes (no space Mtn or PPan) and let us have a fuelrod. That was all. Buyer Beware!

The only plus was that for once- my band actually worked to open the hotel room door!

Later we also talked to a second CM for a short period, and that was even worse. He kept asking us really basic stuff, like did we try turning them on/off, even after we told them we'd already spent 2 hours witha GS CM. It wasn't worth losing even more time, so we just gave up.
 

DisneyfanMA

Well-Known Member
Wanted to share in this thread we are just back, and we were never able to get all our bands working properly at the same time. They arrived before our visit, and we charged them, and tried to pair them before the trip. We were not able to play the games.

During the trip though, we'd get one or two to work for a few hours, but not all at once. Then a few hours later or the next day, that band would stop working. I think one of them never fully worked.

We spent more than 2 hours in GS trying to get them to fully pair properly, but even the CM could not get them to fully pair. We got one of them to work for few hours. She said it was a known issue with Android devices. CM said w/Android it helps if everything is fully charged, but that didn't seem to do anything. She filled out an incident report.

We tried everything, and it was frustrating. She even had us delete and replace MDE. Nothing. We all have Android devices, but all different ones. Maybe they pair better with Apple?

If even the GS CM can't get the stupid things to work...


The bands did work like regular M-bands, and sometimes they would randomly light up. Sometimes we could get one or two to scan at the statues, but then the next day or so, the ones we had collected would disappear, like we had not collected any. We could not collect Pinocchio at all. (Though the audio would play.)

They also kept popping off our wrists like no Magicbands before. Right form the first day, but the problem got worse the more we took them off.

Also, we knew we'd have to charge them, but it was decidedly a hassle. We now have our phone, our band, and a portable powerbank to charge each night. So the whole night stand was covered in two people's cables/devices. Luckily our hotel room had enough outlets. In the past, I generally did not need a powerbank at WDW, but this trip we did.

Also, in the morning, in the heat of trying to eat, get ready, get G+, get to the parks, remembering the band was one more thing to have to keep track of. By itself, no big deal, but with everything else it was just one more thing to have to remember.

They were a complete waste of money, IMO. Despite the fact they did not work, and did not stay on our wrists, we were not offered a refund, which was also disappointing. CM gave us ONE round of G+passes (no space Mtn or PPan) and let us have a fuelrod. That was all. Buyer Beware!

The only plus was that for once- my band actually worked to open the hotel room door!

Later we also talked to a second CM for a short period, and that was even worse. He kept asking us really basic stuff, like did we try turning them on/off, even after we told them we'd already spent 2 hours witha GS CM. It wasn't worth losing even more time, so we just gave up.
Wow. Buyer beware is right. I'd be canceling that charge on my CC or demanding a refund from Disney. They didn't work. Bottom line. Sorry to hear of your disappointment but maybe you'll help someone else.
 

MickeyLuv'r

Well-Known Member
Wow. Buyer beware is right. I'd be canceling that charge on my CC or demanding a refund from Disney. They didn't work. Bottom line. Sorry to hear of your disappointment but maybe you'll help someone else.
Parts of the visit were great (Guardians!), but parts of the trip were not so great. I do plan a follow up email in the next few days. We'll see what happens.

In addition to the above: Two park tickets we had listed in MDE account got eaten/used incorrectly. One was a partly used 10-day ticket (from back when they weren't supposed to ever expire), so there was no way to rename it in MDE. We asked to have the correct ticket prioritized, so I'm still unhappy. I just happened to look at MDE on the last day it was incorrectly used and saw 0 days left on a ticket that should have had 6-days. That never should have happened, and if I had not caught it....
 

Chip Chipperson

Well-Known Member
Finally received my MB+ order today. In keeping with the theme started by Disney, the USPS never included the package in my Informed Delivery email and when i checked the tracking on Friday it still said that it was with Disney's shipping vendor, so I had no idea what the package in my mailbox was until I opened it. Now that they've arrived I can't wait to try them out next month.
 

Figments Friend

Well-Known Member
Same here -
My Orange Bird MB+ arrived this afternoon and is currently being charged up with the included wiring.
I would have never have known I was supposed to do this upon arrival as I am surprised to see absolutely NO directions included in the box for set up / getting started.
There are 'directions' on the WDW website / MDE .....but I was assuming at least some kind of clue would be included with the item itself.
Yet another example of why it is a good thing I read this forum....

So, there is no plug included.
Just the 'USB' type Disney specific wiring attached to the 'band cradle' that snaps onto the back of your MB+.
Once plugged into a electrical source, the band glows green briefly and then vibrates.
It then changes to light up in one corner of the 'watch face' in yellow, and slowly 'breathes' on and off as it charges.
As it charges, the color then turns to green in that corner.
I am assuming as the band becomes more and more charged, the green glow extends further around the 'watch face' to show how far along you are in the process.
My guess is that once it is fully charged, the entire 'watch face' glows green.
My band is still charging, so I won't know for sure until tomorrow.....or if someone wants to chime in.
:)

Watching the tracking number for this shipment went fine for my order.
Thought I would mention this since others have been having issues.
My order moved swift once listed as 'shipped" and within a few days it was here at home in MA.
I happened to check again this morning online and saw it was listed as in my city out for delivery.
This was a nice surprise, as at this point last week I was seriously thinking I would not get this in time for my visit, but here we are....

I am interested in trying this out in the Parks as I am not the typical user.
I don't have a cell/smart phone and do not use the WDW /MDE app so cannot 'update' the band or play any of the interactive games.
I do however hope the light up features will still work on their own.
This will be a fun little experiment......to see how it goes.

Looking the new band over, the 'watch face' is indeed slightly larger / thicker then the MB2 design.
The wristband fasteners look and feel the same to me when comparing the two.
Someone mentioned earlier that the wristband fasteners kept coming undone.
For the band I have, they seem to be exactly the same as the MB2 models.

-
 
Last edited:

CntrlFlPete

Well-Known Member
Once plugged into a electrical source, the band glows green briefly and then vibrates.
It then changes to light up in one corner of the 'watch face' in yellow, and slowly 'breathes' on and off as it charges.
As it charges, the color then turns to green in that corner.
I am assuming as the band becomes more and more charged, the green glow extends further around the 'watch face' to show how far along you are in the process.
My guess is that once it is fully charged, the entire 'watch face' glows green.
My band is still charging, so I won't know for sure until tomorrow.....or if someone wants to chime in.
:)



-

Similar experience in being surprised by the lack of instructions. I found instruction on my phone in the MDE. I ended up trying for the update (as that seemed to be the instruction -- nothing worked, not sure how I was to know if the watch was charged -- so I put it in the cradle and charged it. When I returned, I had the one corner green, so I thought it was 1/4 charged--well the one green is all I ever got.

I thought my update went well as it did restart the MB+ but then it said it failed -- the only instruction was to 'reset' the watch -- I finally figured out that deleting/reloading MDE as well as having my phone forget that it was paired to the MB+ (I was stuck where the MDE could not find the MB+ but I guess it was still connected to my phone) so I did get it to work on my own finally.

Shipping is just odd to me since they use that one shipping company (or whatever they are) -- so when I tracked my MB+ they left Davenport, showed up in Austell (or somewhere in GA) about a week later -- then they went to Tampa -- then to my home in......Davenport -- seems silly but that is how MB's travel.

My wife and daughter are the ones that insisted we get the bands -- it let me know that I tapped in (noticed I was good before I saw the green light on the Mickey reader -- it also vibrated a few times when my daughter waved at statues.
 

pdude81

Well-Known Member
I only got one or two greens as well. I think that's 100 but you'd have to check the number in made after pairing to be sure. I think you can pair and check while it's charging though
 

Chip Chipperson

Well-Known Member
I only got one or two greens as well. I think that's 100 but you'd have to check the number in made after pairing to be sure. I think you can pair and check while it's charging though

When I charged mine, it only said "Charging" in the app but didn't give a percentage orbtell ke when it was fully charged. Only after I took it off the charger did it change to "Full" (but no % given so I'll be interested to see if it changes to a percentage as it drains or just gives vague descriptions like "Low," "Medium," and "Full."
 

Figments Friend

Well-Known Member
Thanks gang.

This morning I see that the band I have had charging all night is also now only 'glowing green' in one corner.
'Green means go' , I am assuming, and I guess I am now fully charged.

I cannot check via any app since I am one of the five people on the planet that do not own a cell / smart phone.
Gonna just 'wing it' and see what happens.

-
 

pdude81

Well-Known Member
When I charged mine, it only said "Charging" in the app but didn't give a percentage orbtell ke when it was fully charged. Only after I took it off the charger did it change to "Full" (but no % given so I'll be interested to see if it changes to a percentage as it drains or just gives vague descriptions like "Low," "Medium," and "Full."
Ok, that makes sense. Mine gave a percentage at the time (2 or so weeks ago), but I don't remember if it was during charging or after. Given what you're sayin it was probably after I paired again. I was able to start the update process while charging but I didn't dare actually apply while plugged in just in case the firmware flashing process was buggy.
 

pdude81

Well-Known Member
Thanks gang.

This morning I see that the band I have had charging all night is also now only 'glowing green' in one corner.
'Green means go' , I am assuming, and I guess I am now fully charged.

I cannot check via any app since I am one of the five people on the planet that do not own a cell / smart phone.
Gonna just 'wing it' and see what happens.

-
Have you mapped it to you in MDE at least? If not, it'll only really let you know statues are nearby. And you won't really be able to play the bounty hunter game without logging in to Play Parks as the person linked to that band.

Also I think you need the app to update them in the first place, which may be necessary to interact with statues these days.
 

Disstevefan1

Well-Known Member
Thanks gang.

This morning I see that the band I have had charging all night is also now only 'glowing green' in one corner.
'Green means go' , I am assuming, and I guess I am now fully charged.

I cannot check via any app since I am one of the five people on the planet that do not own a cell / smart phone.
Gonna just 'wing it' and see what happens.

-
"do not own a cell / smart phone" ...... I d o n' t u n d e r s t a n d :confused:
 

homerdance

Premium Member
We never got our MB+ to syncs with the play Disney app either. So all of the games didn’t work. Which was ok with us, since we had a short vacation and didn’t want to spend the time on the “fillers”.

They need to fix the band falling off super easily ASAP. As much as they charge for these a cheap poorly made clasp is unacceptable.

And it would be good to know why some of these went off when the did.
 

pdude81

Well-Known Member
We never got our MB+ to syncs with the play Disney app either. So all of the games didn’t work. Which was ok with us, since we had a short vacation and didn’t want to spend the time on the “fillers”.

They need to fix the band falling off super easily ASAP. As much as they charge for these a cheap poorly made clasp is unacceptable.

And it would be good to know why some of these went off when the did.
The buzz and the white glow I think meant there is a statue nearby, if that's what you mean by "went off". It's tricky to pair them with the MDE app, then open the appropriate play app to make sure it pulls the right data to see fi you got the statues or not. For a while we thought they weren't working but it was just that the pairing failed again.
 

homerdance

Premium Member
The buzz and the white glow I think meant there is a statue nearby, if that's what you mean by "went off". It's tricky to pair them with the MDE app, then open the appropriate play app to make sure it pulls the right data to see fi you got the statues or not. For a while we thought they weren't working but it was just that the pairing failed again.
It paired fine the issue we had was logging in, and staying logged in, to the play Disney app. That app just sucks. Also, we travel with minors so it didn’t work well with kids without their own cell phones with them.

The bands went off after a ride, around the statues, and at other random times. Not sure what they were trying to tell us.
 

Register on WDWMAGIC. This sidebar will go away, and you'll see fewer ads.

Top Bottom