1. Welcome to the WDWMAGIC.COM Forums!
    Please take a look around, and feel free to sign up and join the community.You can use your Twitter or Facebook account to sign up, or register directly.
    Dismiss Notice

Expedition Everest effects status watch

Discussion in 'WDW Parks General Discussion' started by wdwmagic, Apr 18, 2007.

  1. wdwmagic

    wdwmagic Administrator Moderator

    Joined:
    Jun 4, 2001
    Messages:
    41,798
    Likes Received:
    45,675
    I've had a lot of recent reports that some of Expedition Everest's effects are not currently working.

    As of 15 April 2007:

    - No steam effect at load
    - Second waterfall not running (near the back of the mountain)
    - No bird at the track end scene

    If you ride Everest, and can provide an update as to what is and what isnt working, please do so here. Thanks :)
     
    DebbieG3 likes this.
  2. EpcotServo

    EpcotServo Well-Known Member

    Joined:
    Nov 20, 2005
    Messages:
    8,845
    Likes Received:
    54
    It's very hard to keep up now, management is making lots of "on-the-fly" changes so they can run five trains as I've said in that other thread. Don't be surprised if you see lights on that shouldn't be, effects not working, and a laggy ride system.
     
  3. monorailguy01

    monorailguy01 New Member

    Joined:
    Jul 5, 2006
    Messages:
    511
    Likes Received:
    0
    I was on it last month and the steam and bird were both working fine. As far as the waterfalls I have never seen them working. The only time I seen it working was on opening day other then that I have been on plenty of times with no waterfalls.
     
  4. Skip

    Skip Well-Known Member

    Joined:
    Jan 15, 2007
    Messages:
    860
    Likes Received:
    1,190
    I was on Everest Tuesday of last week and the steam at the load station was not working, the bird was not working (or at least wasn't visible), and I don't believe I saw a second waterfall towards the back (only the one near the Yeti Temple towards the front).

    Hope that helped,

    -Skip
     
  5. doop

    doop Active Member

    Joined:
    Sep 28, 2004
    Messages:
    2,773
    Likes Received:
    30
    The only one I can confirm from two weeks ago was that the steam in the loading station wasn't working, I didn't notice anything else.
     
  6. Eljay

    Eljay Member

    Joined:
    Sep 25, 2002
    Messages:
    649
    Likes Received:
    0
    Hey! What's with that? I love the steam.:shrug: :veryconfu :(
     
  7. speck76

    speck76 Well-Known Member

    Joined:
    Apr 25, 2004
    Messages:
    12,028
    Likes Received:
    305
    there was no bird last weekend, but sa this is spring, birds are currently migrating, so perhaps the winter species will soon be replaced by a summer species
     
  8. JML42691

    JML42691 Active Member

    Joined:
    Jun 1, 2006
    Messages:
    970
    Likes Received:
    49
    I seem to remember a steam/fog effect at the top of the mountain after you get off the lift hill, but before you enter the cave and the track end. Am I just putting memories in my head or what happened to this. Many videos that I have seen now don't have this.
     
  9. imagineer boy

    imagineer boy Well-Known Member

    Joined:
    Dec 23, 2002
    Messages:
    7,824
    Likes Received:
    1,317
    Now there's a major loss.:lol:

    Seriously, I can't stand that bird.
     
  10. PigletIsMyCat

    PigletIsMyCat Well-Known Member

    Joined:
    Aug 25, 2005
    Messages:
    1,386
    Likes Received:
    1,163
    I was on E:E three times yesterday, and can confirm that there were no steam effects at the load platform. There also was no bird at the end of the track. As for the waterfall, I don't even remember a water fall, but I was surprised yesterday to get wet (wet like spat on) at some point during the ride where I have never gotten wet before. I cannot tell you the exact point. Maybe I'll go back tomorrow and go on another three times, but this time take notes :D
     
    mjem216 likes this.
  11. calicommando

    calicommando Member

    Joined:
    Mar 25, 2006
    Messages:
    384
    Likes Received:
    7
  12. Chape19714

    Chape19714 Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    3,985
    Likes Received:
    28
    I saw steam 2 wks ago, but not on sunday. Mist still is missing. The bird seems to be working, but they have changed the timing of how often he appears, so it's about every other time.

    Yeti was in "B" mode on Sunday.
     
  13. the-reason14

    the-reason14 Well-Known Member

    Joined:
    May 5, 2004
    Messages:
    3,708
    Likes Received:
    282
    On my spring break trip one of the waterfall was barely working.
     
  14. SoFlaDisneyFan

    SoFlaDisneyFan New Member

    Joined:
    Jun 4, 2005
    Messages:
    223
    Likes Received:
    0
    The steam from the train and plastic bird seem to work every other, or every few rides for me. As for the waterfall, I can only remember seeing it running ONCE...and that was for the Annual Pass Preview in January 2006. Same goes for the cold mist in the cave before you reach the broken track. Where the heck did that cold mist go!? The only time it worked was for the COLD January morning of the Annual Pass Preview! I want it on the humid, stale, EVIL HOT Florida summer days!:shrug:
     
  15. Skip

    Skip Well-Known Member

    Joined:
    Jan 15, 2007
    Messages:
    860
    Likes Received:
    1,190
    If I remember correctly the mist interfered with the tracks reconfiguring it, causing breakdowns. It sounded like a neat effect (especially since Everest doesn't have too many effects anyway), but I'd rather have no mist than a broken Everest.

    -Skip
     
    DebbieG3 likes this.
  16. lpet11984

    lpet11984 Well-Known Member

    Joined:
    Oct 3, 2005
    Messages:
    1,026
    Likes Received:
    56
    I was going to say, no bird is more of a good thing... :lookaroun



    Couldn't agree with you more. :wave:
     
  17. scottnj1966

    scottnj1966 Well-Known Member

    Joined:
    Mar 12, 2003
    Messages:
    1,322
    Likes Received:
    99
    I always thought that bird effect was put their temporary during the passholder opening until they were done with the real effect. I was so surprised to keep seeing it now.
    It looks so bad and so cheesy.

    Steam was off only one time riding.
    Never seen the waterfall working.
     
  18. PigletIsMyCat

    PigletIsMyCat Well-Known Member

    Joined:
    Aug 25, 2005
    Messages:
    1,386
    Likes Received:
    1,163
    I just rode Expedition: Everest again today, paying special attention to the items that we've been talking about.

    The steam effect is working. At the load platform, there is steam coming out of the last car of the train when it pulls to a stop and right before it pulls away.

    I had never noticed waterfalls before, but I specifically looked today. On your way up the first big hill (into that weird yeti temple) there are waterfall areas on both the left and right sides of the tracks. The right side is visible from the ground in front of the ride (let me know if I'm looking at the right waterfalls lol). The left hand waterfall was NOT working, it wasn't even wet. The right side waterfall, that you can see from in front of E:E, was running.

    The bird at the end of the track is still absent. The bird cry can still be heard, though.

    As for the cold mist, I'm not sure I remember exactly where it used to be, but the only 'cool' place was in the cave where you see the yeti shadow. It is by no means a cold mist, so I'm guessing the cold mist thing is gone as well.
     
  19. wdwmagic

    wdwmagic Original Poster Administrator Moderator

    Joined:
    Jun 4, 2001
    Messages:
    41,798
    Likes Received:
    45,675
    Thanks for the update. Glad to hear the station steam is back.
     
  20. danv3

    danv3 Well-Known Member

    Joined:
    Apr 24, 2007
    Messages:
    1,036
    Likes Received:
    2,278
    Forgive a new poster for asking a question that's undoubtedly in a FAQ somewhere, but what's the deal with the Yeti being in A or B mode? I've never ridden Everest (will do so in November) but I've got the basic idea of what the ride is like.
     

Share This Page